升级 react-native 到 v0.29.x 后 Android 平台部分插件无法使用的问题

首先我们来看一下官方的 Changelog 这个版本有哪些 breaking changes。其中大部分变更暂时我还没有使用到,所以就忽略。但是 Android 有个变更貌似改变挺大了,也直接导致了大部分的第三方插件直接无法使用

1
2
3
Change the application template (49f20f4) - @foghina
* Plugins which pass activity reference in the constructor need to be updated to extend ReactContextBaseJavaModule use getCurrentActivity to get the activity reference. This change is backward compatible.
* Apps need to be migrated to use the latest template

大概的意思是:这个版本我们变更了 APP 的模板,如果你的插件选择在构造函数中传递当前的 activity,那么在这个版本中需要升级到通过继承 ReactContextBaseJavaModule 来获取当前的 activity,这个改变是可以向下兼容的。
Continue reading

  • Page 1 of 1

BelinChung


Guangzhou China